适配 iOS 10 的注意事项


            
2016-09-18 16:49 | iOS

回答:

1、升级到 SDK 版本。

SDK从2.7.2开始做ios10适配,建议使用2.7.2 及其之后的版本


2、权限问题。

iOS 10 在使用摄像头、麦克风、定位、相册等功能的时候,会检查相应权限。App 需要在您 App 的 info.plist 中添加相应权限的说明,否则在 iOS 10 上会 crash。

plist.png

如 SDK 用到的相关功能:


麦克风权限:

Privacy - Microphone Usage Description 

XXX需要使用您的麦克风
相机权限: 

Privacy - Camera Usage Description 

XXX需要使用您的相机
相册权限:

Privacy - Photo Library Usage Description 

XXX需要访问您的相册

定位权限:

Privacy - Location When In Use Usage Description  

XXX需要获取地理位置信息
定位权限: 

Privacy - Location Always Usage Description 

XXX需要在后台获取地理位置信息


PS:上面的中文提示您可以按照您的产品需求进行定制。


3、远程推送。

在 App 设置中,Capabilities -> Push Notifications 务必记得要开启,否则在 iOS 10 中会获取不到 deviceToken。

apns.png


您认为此回答对您有帮助?

共有 57 位开发者认为此问题有帮助

我对此仍有疑问!继续追问