使用 CocoaPods 升级 SDK 后编译报错:Library not found for *

SDK 从 4 打头的版本升级至 5 打头的版本后部分库的命名有变更,使用 CocoaPods 时升级 SDK 后编译报错,报错内容为 Library/Framework not found for *,* 为旧版融云 SDK 中存在的类库
发布时间: 2021-11-22 14:26

回答:

检查项目 Build Settings -> Other Linker Flags 中是否有手动引入旧版 SDK 中的相关文件,如果有需要删除,此项配置下一般只需要保留 $(inherited) 以及自己项目明确需要引入的文件即可