5.1.1 及其以上版本升级注意事项

发布时间: 2021-06-02 14:55

回答:

iOS 5.1.1 版本变更为 XCFramework,需要 pod 升级到 1.10.0 及其以上版本,否则可能会出现以下问题


> 1.运行 APP 或者打包 APP 时无法加载 SDK,出现类似下面的报错

dyld: Library not loaded: @rpath/RongChatRoom.framework/RongChatRoom
Referenced from: /var/containers/Bundle/Application/7DF12BD0-BDC4-4E46-BA07-295C0BA89CF2/SealTalk.app/SealTalk
Reason: image not found

> 2.报错 ld: framework not found RandomNames.xcframework

参考 :https://stackoverflow.com/questions/59102554/framework-not-found-xcframework

上述问题的原因是 pod 从 1.10.0 开始完整支持 XCFramework

注:如果不想升级 pod 那么建议使用 5.1.0 及其以前版本